(Advertisements are not shown for registered users)

Several problems - all probably related

Got a problem with your stock CRX? This is where you should start.

Moderator: Moderators

Several problems - all probably related

Postby Charlie » Wed May 10, 2017 11:42 am

The problems:
-stumbling after coasting in gear
-hard to start when engine is warm, turns over but doesn't start
-after it does start it idles really high - like 2-2.5k
-occasional Code 16 (just started, always happens while idling)

I cleaned the IACV and that helped for a while, but it came back a few days later. it was in really rough shape so i just replaced it. Problem solved for about a week... Once it starts, it runs like a champ, although a little rich.

Before i start throwing money at it (fuel injectors, fuel filter, Main Relay, distributor cap/rotor), where should i start?

1990 Si, SOHC non-vtec ZC, mostly stock otherwise
User avatar
Charlie
 
Posts: 538
Joined: Sun Mar 06, 2005 2:00 am
Location: Atlanta

Re: Several problems - all probably related

Postby mossin_90 » Wed May 10, 2017 1:39 pm

always start with the cheapest.
inspect main relay.
all ground cables specially the one at the thermostat housing. this one is the ecu ground.
also check the ground and all power connectors to distributor,fuel injectors and resistor box if equipped.
don't forget to make sure the ignition switch is good, if its bad and vibration gets to it it can cause a random problem.
also once everything said before was checked make sure fuel filter is clean and that there is enough fuel pressure at the fuel rail, this also = inspect fuel pressure regulator(holds vacuum).
and inspect all vacuum hoses.
that will get you busy for a few hours.
post back
'90 CRX DX_5sp
"Maybe it's better that way... memories can be terribly painful, being able to forget is a great blessing"
mossin_90
 
Posts: 1693
Joined: Tue Mar 11, 2008 9:24 am
Location: Florida

Re: Several problems - all probably related

Postby Charlie » Mon May 15, 2017 11:31 am

thank you!

I haven't had a chance to check on all those yet, but i did find a very loose ground. Haven't had any starting issues since i tightened it!

I'll get on the rest soon.
User avatar
Charlie
 
Posts: 538
Joined: Sun Mar 06, 2005 2:00 am
Location: Atlanta


Return to Stock Garage

Who is online

Users browsing this forum: No registered users and 2 guests