(Advertisements are not shown for registered users)

temp needle rises under any electrial load

Engine swaps, bolt-ons, tuning, OBD-1 conversions, forced induction, suspension & brake upgrades, etc.

Moderator: Moderators

temp needle rises under any electrial load

Postby Spriggan » Mon Apr 17, 2017 8:06 pm

1990 dx
b16a
ukdm gauge cluster (150mph)
three gauge pod in place of radio
new wire harness ( no problems there)

everything has been working for years, few days ago installed the ukdm cluster

all lights worked and so did the dimmer switch. I was able to drive around for one whole day before it started to have problems.

first the lighting ground wire to my 3 gauge pod started smoking, this was bolted to the cluster ground.
unplugged the power and ground from gauges and continued driving

then the cluster's temp gauge would rise under any electrical load once it hits operating temp

checked and re-pinned the cluster, every light works as it should.
checked, cleaned and re-tightened every ground on the car, extra grounds on headlights, starter, alternator.
wired together the dimmer switch (info is the uk and edm cars did not have the dimmer, only some germans ones.)
this made a small difference but the temp needle would still climb
pulled fuses one by one and nothing changed
replaced coolant temp sending unit, no change
plugged in original cluster and the problem was still there
battery is reading 13.9 - 15v...


since this happens under any electrical load and the battery voltage is a little high I am thinking the voltage regulator in the alternator is going but the connection to the temp gauge has me unsure...


I'm stumped!

Ryan

edit: I jumped the brightness control wires at the knob, not at the control unit under the dash, I will try that in the coming days
Spriggan
 
Posts: 418
Joined: Mon Dec 01, 2008 6:52 am
Location: Montauk, NY

Re: temp needle rises under any electrial load

Postby Spriggan » Tue Apr 18, 2017 6:55 pm

jumped the red and black wires at the under dash unit with no change.

while driving around with high beams, hazards, and rear defroster the temp needle stayed at operating temp...assuming the rpms moving the alternator are helping with charging a weak system? back down to idle and the temp gauge goes right up with all the electrical load...15volts from the battery at idle would be either a weak battery or something with the voltage regulator? still don't know why the temp gauge is fluctuating or the ground wires went hot
Spriggan
 
Posts: 418
Joined: Mon Dec 01, 2008 6:52 am
Location: Montauk, NY

Re: temp needle rises under any electrial load

Postby Spriggan » Thu Apr 20, 2017 10:30 pm

removed the plastic cover around the combination meter, someone has previously taken the headlight/signal switch off and did not feel the screws that hold it in were necessary...not the cause of the problem but another problem to add to the list.

tested the battery under full load and it would bounce from 0 to 14 volts, never steady. seems that the voltage regulator might be it...will be checking the diodes sometime soon just to rule it out.
Spriggan
 
Posts: 418
Joined: Mon Dec 01, 2008 6:52 am
Location: Montauk, NY


Return to Modification Garage

Who is online

Users browsing this forum: No registered users and 11 guests