(Advertisements are not shown for registered users)

Broken Images on certain image hosts

Voice your opinion about the site. Make new suggestions. Vote on changes. An open forum to discuss anything related to the CRX Community site.

Moderator: Moderators

Broken Images on certain image hosts

Postby windraver » Thu Apr 04, 2019 6:46 pm

Is there some blocking mechanism preventing certain image hosts from displaying images successfully?

You can see my tests below along with their hosts.

Brinkster.com
http://windraver.net/images/Automotive/ ... MG3744.jpg
Image

Brinkster image host test on a different site:
https://www.w3schools.com/code/tryit.as ... RF4PSHDR2T

Siteground
http://windy-design.com/Windraver/galle ... MG3744.jpg
Image
I just noticed I'm never playing by the rules
Wind's Pop-up Headlights
User avatar
windraver
 
Posts: 1739
Joined: Sun Apr 20, 2008 6:46 am
Location: San Jose, CA

Re: Broken Images on certain image hosts

Postby nihkon » Fri Apr 05, 2019 2:40 pm

It was part of a security update that happened last year. Only images hosted from a secure site work from that point. Meaning, it has to have the "https" in the url. That's why your bottom image works, but the rest don't.

Your "Brinkster image host test on a different site:" test does have the https tag...but it doesn't look to be a link to an image?
User avatar
nihkon
Moderator
 
Posts: 3590
Joined: Thu Mar 17, 2005 4:34 am
Location: SoCal

Re: Broken Images on certain image hosts

Postby windraver » Thu Apr 11, 2019 1:45 pm

nihkon wrote:It was part of a security update that happened last year. Only images hosted from a secure site work from that point. Meaning, it has to have the "https" in the url. That's why your bottom image works, but the rest don't.

Your "Brinkster image host test on a different site:" test does have the https tag...but it doesn't look to be a link to an image?


Thanks, that makes a lot of sense. My brinkster server doesn't redirect to HTTPS while my sitegrounds website does the redirect to HTTPS which allow it to work. Thanks for solving the mystery.

Now to find a way to get my pictures working again on all the old urls.
I just noticed I'm never playing by the rules
Wind's Pop-up Headlights
User avatar
windraver
 
Posts: 1739
Joined: Sun Apr 20, 2008 6:46 am
Location: San Jose, CA

Re: Broken Images on certain image hosts

Postby AG_admin » Thu Apr 11, 2019 1:51 pm

Link to one? I'll take a look and see what I can do

Kevin
User avatar
AG_admin
 
Posts: 113
Joined: Tue Jun 11, 2013 9:38 am


Return to crxcommunity.com Site Suggestions & Issues

Who is online

Users browsing this forum: No registered users and 3 guests