(Advertisements are not shown for registered users)

Electrical Problem and Engine break in?

Got a problem with your stock CRX? This is where you should start.

Moderator: Moderators

Electrical Problem and Engine break in?

Postby mingus847 » Wed Jun 24, 2020 1:27 am

91 CRX Si. The temperature gauge always goes up when I drive with lights on. I turn the lights off it returns
to normal. All the other gauges are working as they should. Additionally, the blue bright light indicator flickers a little
when it's on. I also need advice on engine break in. The engine is an d16a6 bored to 75mm with 11.5 to 1 pistons, upgraded cam and valves. I want to make sure I break it in properly. I have put break in oil in it and I have driven about 30 mile since I got running well. I know very little about these engines and could use some advice. Thanks.
1991 Black CRx Si
mingus847
 
Posts: 14
Joined: Tue Nov 12, 2019 9:06 pm

Re: Electrical Problem and Engine break in?

Postby ykf7b0 » Mon Jul 06, 2020 8:36 pm

I would change the oil at this point and again after 500, then get on a regular schedule. At least that is how I did mine.
Black 1989 D16A6 si
ykf7b0
 
Posts: 269
Joined: Sat Sep 26, 2015 11:16 am
Location: The South

Re: Electrical Problem and Engine break in?

Postby raffaelli » Thu Jul 09, 2020 9:58 am

Based on this and some of the other issues you are having, you may want to check through the grounding connections.
raffaelli
 
Posts: 258
Joined: Mon Dec 26, 2005 11:15 am
Location: New York


Return to Stock Garage

Who is online

Users browsing this forum: No registered users and 8 guests